Forum

#1 2017-12-07 12:33:56

MegaComputeur
New member

Hide in viewport

Hi,

I'm trying to hide an object in the viewport but keep it present in the render. I think the usual way to do it is to hide it in the object's sceneGraph and then unhide it using an attribute override in the rendergraph. But as soon as I put that attribute, the object reappears in the viewport.

That's also what I found in the doc:
'"Hide the objects inside the high resolution group.
Select all the low resolution objects.
Press the SceneGraphNode → Instances → Edit button to open the Linker.
Select in the right column all the children of the high resolution group. This will instanciate the high resolution models at every low resolution positions.
Add a rule in the RenderGraph to hide the low resolution models. Check the SceneGraphNode → Hidden attribute.
Add a rule in the RenderGraph to show the high resolution models. Uncheck the SceneGraphNode → Hidden attribute."

I am working on guerilla 2.0b7. I tried the same process on guerilla 1.4 and it works like I want it to, so it seems it is a version 2 related issue i think.


Thanks,
MegaComputeur

Offline

 

#2 2017-12-07 16:05:30

Ben
Guerilla dev, the guy to hug

Re: Hide in viewport

Right now, you can't really disable an object from being totally invisible in the viewport.
Guerilla 2.0 now shows the viewport as it is rendered. The OpenGL > Display Mode only applies to the raytraced viewport.
We'll make so all views are consistent.

You can, in the mean time, turn the objects to bounding boxes using OpenGL > OpenGL Display mode.

Ben


Benjamin 'Ben' Legros
Guerilla developer
http://www.guerillarender.com

Offline

 

#3 2017-12-07 18:02:57

MegaComputeur
New member

Re: Hide in viewport

Hello, thank for the reply.

I have a case where I instanciate a bunch of proxies with high poly trees. Each tree is made of lots and lots of objects (that I need to stay separated objects in order to have guerilla automaticaly instanciate them when the shape is identical, like the leaves) and the OpenGL box mode gives me an insane amount of boxes, and I still struggle to turn around in my scene.

I tried switching to the new viewport and it seems to be fluid enough to work with, or do you discourage me to do so ? If not, is there a way to set this viewport as default ?

thanks

Offline

 

#4 2017-12-07 21:36:49

Ben
Guerilla dev, the guy to hug

Re: Hide in viewport

Hi,

Well for the time being, the raytrace viewport is functional but lacks a bit of features to be the only viewport available, hence we still support the OpenGL viewport.
If you can just wait a few days, I'm about to release a new version, and I'll make so the raytraced viewport and opengl viewport share the same settings (that is turning off an object in the viewport both in gl and raytrace ...)

Ben


Benjamin 'Ben' Legros
Guerilla developer
http://www.guerillarender.com

Offline

 

#5 2017-12-07 21:38:06

Ben
Guerilla dev, the guy to hug

Re: Hide in viewport

By the way, the raytrace viewport IS really the view for such cases where you have too much geo to display in GL smile


Benjamin 'Ben' Legros
Guerilla developer
http://www.guerillarender.com

Offline

 

#6 2017-12-08 10:07:29

MegaComputeur
New member

Re: Hide in viewport

Awesome thanks smile

Offline

 

Board footer

Powered by PunBB
© Copyright 2002–2008 PunBB