Forum

  • Index
  •  » Rendering
  •  » no eye highlight on character wearing glasses

#1 2017-04-10 17:18:00

sachalek
Member

no eye highlight on character wearing glasses

Hello,
Our character's eyeglasses are blocking the highlight in the Guerilla eye shader. Is there any way to fix that?
Thanks,
Sarah

Offline

 

#2 2017-04-14 13:28:15

Bricky Rick
Member

Re: no eye highlight on character wearing glasses

Hi,
You could try rendering glasses and eyes separately!


Antonin Bric
VFX student
https://vimeo.com/user45785791

Offline

 

#3 2017-04-15 16:34:29

Gam
Member

Re: no eye highlight on character wearing glasses

Hi

You must switch double side to single or thin mode

Cheers

Offline

 

#4 2017-04-18 11:34:39

hulud
Guerilla dev, the guy to hug

Re: no eye highlight on character wearing glasses

Hi,

1) First, it may be good to remove the glasses objects from the "Shadows" set and the "Reflection" set.

2) If you are using the fake highlight of the Eye shader :

The shader is blocking the fake highlight after the first bounce to remove fireflies. Put this fixed Eye shader in your project. This fix will be also available in Guerilla 1.4.13.


Cyril 'Hulud' Corvazier
Guerilla developer
http://www.mercs-eng.com

Offline

 

#5 2017-04-20 17:42:37

sachalek
Member

Re: no eye highlight on character wearing glasses

Thank you! The new eye shader works. I took me a while to see the message because I don't get email notifications.

Another eye highlight question... Is it possible to change the softness of the highlight? Right now it's very sharp and the "smooth" parameter doesn't do much. Maybe it's because the scale of our characters is very big. It's not that important.

Offline

 
  • Index
  •  » Rendering
  •  » no eye highlight on character wearing glasses

Board footer

Powered by PunBB
© Copyright 2002–2008 PunBB