#1 2018-01-23 22:01:10

Yeti and displacement


Maybe I misunterstand how displacement work in guerilla, but I can't get yeti work with displacement. The yeti fur didn't match with the mesh displaced.

The displacement map is generated in ZBrush. I try a lot of mixed parameters, but usally with these:

- Adaptive = On
- SmoothUV = On
- DPSubPix = 4
- Mid = 0.5
- Scale = 1
- Intensity = 0
- 3 Channels = On
- 32Bits = On
- Exr = On
- FlipV = On (multi map exporter in Zbrush)

Yeti displacement is done in maya, in the yeti graph with a displacement node. (displacement node in Yeti)

In guerilla, I add a displacement node, with displacement + bump, and amount set to 1.

Maybe it's in relation with the Normalization, Offset and Multiplier ?

It's not obvious, the use of displacement map is quite vague.

It work pretty well in Arnold with a mid set to 0. (displacement node for Arnold)


Last edited by Nicolas Castelli (2018-01-23 22:05:39)



#2 2018-01-24 17:14:01

Guerilla dev, the guy to hug

Re: Yeti and displacement


The Normalization modes tell how the displacement map should be interpreted:

Normalize: the displacement final amount = clamp ((Amount - Offset) * Multiplier, -1, 1) * Displacement Amount
Offset is the displacement map neutral point, Multipler is the displacement gain to get to [-1,1].
The overall Displacement strength is controlled by the Displacement > Displacement Amount attribute.
The clamp is intended to avoid displacement cracks when the displacement is going out of the [-1,1] range before being scaled by Displacement Amount.
This is usually for displacement maps in the [0,1] range, with 0.5 neutral point.

Affine: the displacement final amount = (Amount - Offset) * Multiplier
This is essentially the same, but without clamping and multiplication by the Displacement > Displacement Amount attribute.
If your texture is a raw export, then you can use this mode with Offset = 0 and Multiplier = 1. You must then adjust the Displacement > Displacement Amount attribute to extend the object bounding box to avoid displacement cracks.

Raw: the displacement final amount = Amount
No treatment of the Amount, this is the same as using Affine with Offset = 0 and Multiplier = 1.

So, from your ZBrush export settings, I guess the Affine/Raw modes with Offset=0 and Multiplier=1 should do it. Just make sure that the Displacement > Displacement Amount is consistent (that is the maximum absolute value from the displacement map) to avoid cracks.


Benjamin 'Ben' Legros
Guerilla developer



Board footer

Powered by PunBB
© Copyright 2002–2008 PunBB